.Net version for expressmaint 2008

Oct 23, 2012 at 9:46 AM
Edited Oct 23, 2012 at 9:46 AM

I have server 2008 R2 and installed the expressmaint 2008 version but when I run it, it initially complains about the runtime and since upgrading to .net 4.5 complains that "this application could not be started" which appears to be(from http://support.microsoft.com/kb/2715633?version=(null)&processName=ExpressMaint.exe&platform=0009&osver=5&isServer=1) a shim error with .net and means:

SHIM_NOVERSION_FOUND

Message: "This application could not be started."

The app is not configured in a way that makes it possible to determine the appropriate version of the .NET Framework runtime. You can't fix the configuration problem yourself. Contact the app vendor to resolve the issue.

so, my questions are:

a) Which version of .Net is supported by expressmaint 2008

b) I understood all versions of .Net framework to be conclusive  i.e. they have all the previous versions included, so why wouldnt this work if expressmaint is built for an earlier version?

c) how do I go about getting this fixed?  I have other apps that actively use .net framework so dont really want to have to uninstall and reinstall it.

Thanks in advance

Rob