Unified ExpressMaint for all sql server versions

Jun 25, 2009 at 3:24 PM

Hi, I have a question:

Why not unified this great utility, so the same exe can work with any version of sql server (2000/5/8/...) ??

And also add 7zip compression ???

Reggards, Emito.

 

Coordinator
Jun 25, 2009 at 4:24 PM

Because the tool uses SMO and would require users to install SQL 2008 SMO (or whatever the latest version is) on downlevel installations if there was only one "latest" version. I am rewriting it completely to remove the SMO dependency and thus in the future there will be one version supporting 2000-2008+

Because the tool is targeted at SQL Express and it has a 4GB file limit compression was considered less of an issue than with higher editions. Also the compression would need to be done after the backup file had been created so you might as well use something like the compact command that is part of Windows to perform the compression as bart of a batch file e.g.

@echo off
expressmaint -s (local)\SQL2005 -T DB -D ALL_SYSTEM -B C:\Backups -BU DAYS -BV 1 -R C:\Reports -RU DAYS -RV 1
compact /C /S:C:\Backups /Q *.bak

It is something that I might look at again in the future if there is enough demand for it.

Jun 25, 2009 at 9:04 PM

First, thanks for your answer jaspersmith.

I'll be waiting for the new version (without smo), I'm still with a lot of Sql 2000 databases and would be nice to have the same program for all sql versions.

Emito.